Skip to end of metadata
Go to start of metadata
Tämän sivun sisältö:
 
 

Johdanto

Varayhteys voidaan toteuttaa joko yhdellä tai kahdella reunalaitteella.

Yhden reunalaitteen mallissa external BGP (EBGP) -sessiot luodaan asiakasreunalaitteen ja kahden Funetin reitittimen välille. Sisäverkon IGP-reititysprotokollia (kuten OSPF tai OSPFv3) ei varayhteyden toteuttamiseen tarvita, mutta niitä voidaan kyllä käyttää, jos sisäverkko niitä muuten hyödyntää. EBGP:n apuna voidaan käyttää Bidirectional Forwarding Detection (BFD) -protokollaa, jolla mahdollinen yhteyskatko on mahdollista huomata nopeammin.

Kahden reunalaitteen mallissa EBGP-sessio luodaan molemmista asiakasreunalaitteista johonkin Funetin reitittimeen. Reunalaitteiden välille rakennetaan internal BGP (IBGP) sessio, jolla reunalaitteet vaihtavat reittitietojaan. Sisäverkon reititysprotokollia käytetään reunalaitteiden tekniseen kytkentään, eli mainostamaan laitteiden loopback-liitäntöjä ja reitittimien välisiä linkkiverkkoja. Myös BFD:tä voidaan hyödyntää yhden reitittimen mallin tapaan.

Konfigurointiesimerkeissä on käytetty dokumentointiin varattuja osoiteavaruuksia sekä muita esimerkkiparametrejä kuten verkkoliitännät ja AS-numero, jotka pitää korvata kyseisen toteutuksen tiedoilla. Konfiguraatioesimerkit on lisäksi jaettu kahteen osaan: reitittimien lopullinen konfiguraatio koostuu yhteisestä osasta ja reititinkohtaisesta osasta, joka täydentää yhteistä konfiguraatiota. Tämän ohella on huomioitavaa, että IPv6-konfiguraatio täydentää myös IPv4-konfiguraatiota.

Alla on lyhyesti listattuna parametrit, jotka täytyy muuttaa käyttökohteen mukaisiksi.

Yhden reunalaitteen malli (kuva 1):

  • ge-0/0/0                        (pääyhteyden liitäntä)
  • ge-0/0/1                        (varayhteyden liitäntä)
  • 192.0.2.253                     (reunalaitteen IPv4 loopback -osoite)
  • 192.0.2.240/30                  (pääyhteyden IPv4-linkkiverkko)
  • 192.0.2.244/30                  (varayhteyden IPv4-linkkiverkko)
  • 192.0.2.0/24                    (organisaation IPv4-osoiteavaruus)
  • 2001:DB8:100:FFFF::1/128        (reunalaitteen IPv6 loopback -osoite)
  • 2001:DB8:100:F000::/126         (pääyhteyden IPv6-linkkiverkko)
  • 2001:DB8:100:F001::/126         (varayhteyden IPv6-linkkiverkko)
  • 2001:DB8:100::/48               (organisaation IPv6-osoiteavaruus)
  • 65099                           (organisaation AS-numero, privaatti-AS:n saa Funetilta kysymällä)

Kahden reunalaitteen malli (kuva 2):

  • ge-0/0/0                        (pää- tai varayhteyden liitäntä)
  • ge-0/0/1                        (reunalaitteiden välisen yhteyden liitäntä)
  • 192.0.2.253                     (pääyhteyden reunalaitteen IPv4 loopback -osoite)
  • 192.0.2.254                     (varayhteyden reunalaitteen IPv4 loopback -osoite)
  • 192.0.2.240/30                  (pääyhteyden IPv4-linkkiverkko)
  • 192.0.2.244/30                  (varayhteyden IPv4-linkkiverkko)
  • 192.0.2.248/30                  (reunalaitteiden välinen IPv4-linkkiverkko)
  • 192.0.2.0/24                    (organisaation IPv4-osoiteavaruus)
  • 2001:DB8:100:FFFF::1/128        (pääyhteyden reunalaitteen IPv6 loopback -osoite)
  • 2001:DB8:100:FFFF::2/128        (varayhteyden reunalaitteen IPv6 loopback -osoite)
  • 2001:DB8:100:F000::/126         (pääyhteyden IPv6-linkkiverkko)
  • 2001:DB8:100:F001::/126         (varayhteyden IPv6-linkkiverkko)
  • 2001:DB8:100:F002::/126         (reunalaitteiden välinen IPv6-linkkiverkko)
  • 2001:DB8:100::/48               (organisaation IPv6-osoiteavaruus)
  • 65099                           (organisaation AS-numero, privaatti-AS:n saa Funetilta kysymällä)

Vaihtoehdoista löytyy havainnekuvia (kuvat 1-2) alempaa konfiguraatioesimerkkien keskeltä.

BGP-varayhteys (yhteiset konfiguraatiot kaikkiin reitittimiin)

IPv4-konfiguraatiot (sisältäen yleiset asetukset)

interfaces {
    lo0 {
        unit 0 { 
            family inet {
                address 127.0.0.1/32;
            }
        }
    }
}
routing-options {
    /* Staattinen IPv4 discard-reitti omille osoiteprefikseille */
    static {
        route 192.0.2.0/24 {
            discard;
            retain;
            preference 254;
        }
    }
    /* BGP: oma AS-numero */
    autonomous-system 65099;
    /* Rajoitetaan next-hop:n resolvointia */
    resolution {
        rib inet.0 {
            import IPV4-RESOLVING;
        }
        rib inet.2 {
            import IPV4-RESOLVING;
        }
    }
}
protocols {
    bgp {
        /* Suoritetaan tarkistus BGP-yhteyden polun MTU:lle */
        mtu-discovery;
        /* Lokitetaan BGP-sessioiden heilumiset */
        log-updown;
        /* Ryhmä IPv4 Funet EBGP-peerauksia varten */
        group IPV4-FUNET {
            /* Käytetään EBGP:tä */
            type external;
            /* Asetetaan BGP holdtime 20s */
            hold-time 20;
            /* Suodatetaan Funetin mainostuksia (default-reitti) */
            import BGP-IPV4-FUNET-IN;
            /* Suodatetaan omia mainostuksia (omat prefiksit) */
            export BGP-IPV4-FUNET-OUT;
            /* Hyväksytään IPv4 unicast ja multicast -peeraukset */
            family inet {
                any;
            }
            /* Peerauskumppanin AS-numero (Funet) */
            peer-as 1741;
        }
    }
}
policy-options {
    /* Määritetään IPv4 default-prefiksi */
    prefix-list IPV4-DEFAULT {
        0.0.0.0/0;
    }
    /* Määritetään IPv4 multicast-prefiksi */
    prefix-list IPV4-MULTICAST {
        224.0.0.0/4;
    }
    /* Määritetään omat IPv4-prefiksit */
    prefix-list IPV4-OWN-PREFIXES {
        192.0.2.0/24;
    }
    /* Määritetään IPv4 Funet -linkkiverkkojen prefiksit */
    prefix-list IPV4-LINK-NETWORKS {
        192.0.2.240/30;
        192.0.2.244/30;
    }
    /* Määritetään policy Funetin IPv4 BGP-mainostuksille (default) */
    policy-statement BGP-IPV4-FUNET-IN {
        term ACCEPT-IPV4-DEFAULT-ROUTE {
            from {
                prefix-list IPV4-DEFAULT;
            }
            then accept;
        }
        then reject;
    }
    /* Määritetään policy omille IPv4 BGP-mainostuksille (omat prefiksit) */
    policy-statement BGP-IPV4-FUNET-OUT {
        term ACCEPT-IPV4-OWN-PREFIXES {
            from {
                prefix-list IPV4-OWN-PREFIXES;
            }
            then accept;
        }
        then reject;
    }
    /* Määritetään policy IPv4-reittien resolvonnille */
    policy-statement IPV4-RESOLVING {
        term REJECT-BGP-AND-STATIC-ROUTES {
            from protocol [ bgp static ];
            then reject;
        }
        term REJECT-DEFAULT-AND-OWN-PREFIXES {
            from {
                prefix-list IPV4-DEFAULT;
                prefix-list IPV4-OWN-PREFIXES;
            }
            then reject;
        }
        then accept;
    }
}
firewall {
    /* Määritetään suodatin IPv4 Funet-yhteydelle (sisääntuleva liikenne) */
    filter FW-IPV4-FUNET-IN {
        /* Hyväksytään kaikki linkkiverkosta tuleva liikenne */
        term ACCEPT-LINK-NETWORKS {
            from {
                source-prefix-list {
                    IPV4-LINK-NETWORKS;
                }
            }
            then accept;
        }
        /* Hylätään omat prefiksit lähdeosoitteina */
        term DISCARD-SPOOFED-SOURCE {
            from {
                source-prefix-list {
                    IPV4-OWN-PREFIXES;
                }
            }
            then discard;
        }
        /* Hyväksytään omat prefiksit kohdeosoitteina ja multicast */
        term ACCEPT-OWN-AND-MULTICAST-PREFIXES {
            from {
                destination-prefix-list {
                    IPV4-OWN-PREFIXES;
                    IPV4-MULTICAST;
                }
            }
            then accept;
        }
        /* Hylätään muut (laskuri) */
        term DISCARD-OTHERS {
            then {
                discard;
                count fw-ipv4-funet-in-discard;
            }
        }
    }
    /* Määritetään suodatin IPv4 Funet-yhteydelle (ulospäin lähtevä liikenne) */
    filter FW-IPV4-FUNET-OUT {
        /* Hyväksytään kaikki linkkiverkosta lähtevä liikenne */
        term ACCEPT-LINK-NETWORKS {
            from {
                source-prefix-list {
                    IPV4-LINK-NETWORKS;
                }
            }
            then accept;
        }
        /* Hyväksytään omat prefiksit lähdeosoitteina */
        term ACCEPT-OWN-PREFIXES {
            from {
                source-prefix-list {
                    IPV4-OWN-PREFIXES;
                }
            }
            then accept;
        }
        /* Hylätään muut (laskuri) */
        term DISCARD-OTHERS {
            then {
                discard;
                count fw-ipv4-funet-out-discard;
            }
        }
    }
}

 

IPv6-konfiguraatiot (lisäyksenä IPv4-konfiguraatioihin)

routing-options {
    /* Staattinen IPv6 discard-reitti omille osoiteprefikseille */
    rib inet6.0 {
        static {
            route 2001:DB8:100::/48 {
                discard;
                retain;
                preference 254;
            }
        }
    }
    /* Rajoitetaan next-hop:n resolvointia */
    resolution {
        rib inet6.0 {
            import IPV6-RESOLVING;
        }
        rib inet6.2 {
            import IPV6-RESOLVING;
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv6 Funet EBGP-peerauksia varten */
        group IPV6-FUNET {
            /* Käytetään EBGP:tä */
            type external;
            /* Asetetaan BGP holdtime 20s */
            hold-time 20;
            /* Suodatetaan Funetin mainostuksia (default-reitti) */
            import BGP-IPV6-FUNET-IN;
            /* Suodatetaan omia mainostuksia (omat prefiksit) */
            export BGP-IPV6-FUNET-OUT;
            /* Hyväksytään IPv6 unicast ja multicast -peeraukset */
            family inet6 {
                any;
            }
            /* Peerauskumppanin AS-numero (Funet) */
            peer-as 1741;
        }
    }
}
policy-options {
    /* Määritetään IPv6 default-prefiksi */
    prefix-list IPV6-DEFAULT {
        ::/0;
    }
    /* Määritetään IPv6 link-local -prefiksi */
    prefix-list IPV6-LINK-LOCAL {
        FE80::/10;
    }
    /* Määritetään IPv6 multicast-prefiksi */
    prefix-list IPV6-MULTICAST {
        FF00::/8;
    }
    /* Määritetään omat IPv6-prefiksit */
    prefix-list IPV6-OWN-PREFIXES {
        2001:DB8:100::/48;
    }
    /* Määritetään IPv6 Funet -linkkiverkkojen prefiksit */
    prefix-list IPV6-LINK-NETWORKS {
        2001:DB8:100:F000::/126;
        2001:DB8:100:F001::/126;
    }
    /* Määritetään policy Funetin IPv6 BGP-mainostuksille (default) */
    policy-statement BGP-IPV6-FUNET-IN {
        term ACCEPT-IPV6-DEFAULT-ROUTE {
            from {
                prefix-list IPV6-DEFAULT;
            }
            then accept;
        }
        then reject;
    }
    /* Määritetään policy omille IPv6 BGP-mainostuksille (omat prefiksit) */
    policy-statement BGP-IPV6-FUNET-OUT {
        term ACCEPT-IPV6-OWN-PREFIXES {
            from {
                prefix-list IPV6-OWN-PREFIXES;
            }
            then accept;
        }
        then reject;
    }
    /* Määritetään policy IPv6-reittien resolvonnille */
    policy-statement IPV6-RESOLVING {
        term REJECT-BGP-AND-STATIC-ROUTES {
            from protocol [ bgp static ];
            then reject;
        }
        term REJECT-DEFAULT-AND-OWN-PREFIXES {
            from {
                prefix-list IPV6-DEFAULT;
                prefix-list IPV6-OWN-PREFIXES;
            }
            then reject;
        }
        then accept;
    }
}
firewall {
    family inet6 {
        /* Määritetään suodatin IPv6 Funet-yhteydelle (sisääntuleva liikenne) */
        filter FW-IPV6-FUNET-IN {
            /* Hyväksytään kaikki linkkiverkosta tuleva liikenne */
            term ACCEPT-LINK-NETWORKS {
                from {
                    source-prefix-list {
                        IPV6-LINK-LOCAL;
                        IPV6-LINK-NETWORKS;
                    }
                }
                then accept;
            }
            /* Hylätään omat prefiksit lähdeosoitteina */
            term DISCARD-SPOOFED-SOURCE {
                from {
                    source-prefix-list {
                        IPV6-OWN-PREFIXES;
                    }
                }
                then discard;
            }
            /* Hyväksytään omat prefiksit kohdeosoitteina ja multicast */
            term ACCEPT-OWN-AND-MULTICAST-PREFIXES {
                from {
                    destination-prefix-list {
                        IPV6-LINK-LOCAL;
                        IPV6-OWN-PREFIXES;
                        IPV6-MULTICAST;
                    }
                }
                then accept;
            }
            /* Hylätään muut (laskuri) */
            term DISCARD-OTHERS {
                then {
                    discard;
                    count fw-ipv6-funet-in-discard;
                }
            }
        }
        /* Määritetään suodatin IPv6 Funet-yhteydelle (ulospäin lähtevä liikenne) */
        filter FW-IPV6-FUNET-OUT {
            /* Hyväksytään kaikki linkkiverkosta lähtevä liikenne */
            term ACCEPT-LINK-NETWORKS {
                from {
                    source-prefix-list {
                        IPV6-LINK-LOCAL;
                        IPV6-LINK-NETWORKS;
                    }
                }
                then accept;
            }
            /* Hyväksytään omat prefiksit lähdeosoitteina */
            term ACCEPT-OWN-PREFIXES {
                from {
                    source-prefix-list {
                        IPV6-OWN-PREFIXES;
                    }
                }
                then accept;
            }
            /* Hylätään muut (laskuri) */
            term DISCARD-OTHERS {
                then {
                    discard;
                    count fw-ipv6-funet-out-discard;
                }
            }
        }
    }
}

 

BGP-varayhteys yhdellä reitittimellä (BFD)

 

Kuva 1: BGP-varayhteys yhdellä reitittimellä BFD:n kanssa

 

Customer rtr1 (IPv4)

interfaces {
    /* Funet-pääyhteyden liitäntä ge-0/0/0 */
    ge-0/0/0 {
        description "Funet primary";
        unit 0 {
            /* IPv4-linkkiverkko ja suodatukset Funet-pääyhteydellä */
            family inet {
                filter {
                    input FW-IPV4-FUNET-IN;
                    output FW-IPV4-FUNET-OUT;
                }
                address 192.0.2.241/30;
            }
        }
    }
    /* Funet-varayhteyden liitäntä ge-0/0/1 */
    ge-0/0/1 {
        description "Funet secondary";
        unit 0 {
            /* IPv4-linkkiverkko ja suodatukset Funet-varayhteydellä */
            family inet {
                filter {
                    input FW-IPV4-FUNET-IN;
                    output FW-IPV4-FUNET-OUT;
                }
                address 192.0.2.245/30;
            }
        }
    }
    /* Reitittimen loopback (reitittimen oma osoite) */
    lo0 {
        unit 0 { 
            /* Reitittimen IPv4-osoite, määritetään ensisijaiseksi */
            family inet {
                address 192.0.2.253/32 {
                    primary;
                    preferred;
                }
            }
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv4 Funet EBGP-peerauksia varten */
        group IPV4-FUNET {
            /* Pääyhteyden IPv4 BGP-peeraus */
            neighbor 192.0.2.242 {
                description "BGP peering with AS1741 - primary";
                /* Käytetään BFD:tä BGP-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
               }
            }
            /* Varayhteyden IPv4 BGP-peeraus */
            neighbor 192.0.2.246 {
                description "BGP peering with AS1741 - secondary";
                /* Käytetään BFD:tä BGP-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
}

 

Customer rtr1 (IPv6)

interfaces {
    /* Funet-pääyhteyden liitäntä ge-0/0/0 */
    ge-0/0/0 {
        unit 0 {
            /* IPv6-linkkiverkko ja suodatukset Funet-pääyhteydellä */
            family inet6 {
                filter {
                    input FW-IPV6-FUNET-IN;
                    output FW-IPV6-FUNET-OUT;
                }
                address 2001:DB8:100:F000::1/126;
            }
        }
    }
    /* Funet-varayhteyden liitäntä ge-0/0/1 */
    ge-0/0/1 {
        unit 0 {
            /* IPv6-linkkiverkko ja suodatukset Funet-varayhteydellä */
            family inet6 {
                filter {
                    input FW-IPV6-FUNET-IN;
                    output FW-IPV6-FUNET-OUT;
                }
                address 2001:DB8:100:F001::1/126;
            }
        }
    }
    /* Reitittimen loopback (reitittimen oma osoite) */
    lo0 {
        unit 0 { 
            /* Reitittimen IPv6-osoite, määritetään ensisijaiseksi */
            family inet6 {
                address 2001:DB8:100:FFFF::1/128 {
                    primary;
                    preferred;
                }
            }
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv6 Funet EBGP-peerauksia varten */
        group IPV6-FUNET {
            /* Pääyhteyden IPv6 BGP-peeraus */
            neighbor 2001:DB8:100:F000::2 {
                description "IPv6 BGP peering with AS1741 - primary";
            }
            /* Varayhteyden IPv6 BGP-peeraus */
            neighbor 2001:DB8:100:F001::2 {
                description "IPv6 BGP peering with AS1741 - secondary";
            }
        }
    }
}

 

BGP-varayhteys kahdella reitittimellä (BFD)

 

Kuva 2: BGP-varayhteys kahdella reitittimellä BFD:n kanssa

 

Customer rtr1 (IPv4)

interfaces {
    /* Funet-pääyhteyden liitäntä ge-0/0/0 */
    ge-0/0/0 {
        description "Funet primary";
        unit 0 {
            /* IPv4-linkkiverkko ja suodatukset Funet-pääyhteydellä */
            family inet {
                filter {
                    input FW-IPV4-FUNET-IN;
                    output FW-IPV4-FUNET-OUT;
                }
                address 192.0.2.241/30;
            }
        }
    }
    /* Omien reitittimien (rtr1 - rtr2) välinen liitäntä ge-0/0/1 */
    ge-0/0/1 {
        description "rtr1 - rtr2";
        unit 0 {
            /* IPv4-linkkiverkko reitittimien välisellä yhteydellä */
            family inet {
                address 192.0.2.249/30;
            }
        }
    }
    /* Reitittimen loopback (reitittimen oma osoite) */
    lo0 {
        unit 0 {
            /* Reitittimen IPv4-osoite, määritetään ensisijaiseksi */
            family inet {
                address 192.0.2.253/32 {
                    primary;
                    preferred;
                }
            }
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv4 IBGP-peerauksia varten */
        group IPV4-INTERNAL {
            /* Käytetään IBGP:tä */
            type internal;
            /* Mainostetaan aina ulkoa opitut reitit */
            advertise-external;
            /* Asetetaan BGP holdtime 20s */
            hold-time 20;
            /* Hyväksytään IPv4 unicast ja multicast -peeraukset */
            family inet {
                any;
            }
            /* Peerauskumppanin AS-numero (oma) */
            peer-as 65099;
            /* IPv4 IBGP-peeraus */
            neighbor 192.0.2.254 {
                description "IBGP peering with AS65099 - rtr2";
            }
        }
        /* Ryhmä IPv4 Funet EBGP-peerauksia varten */
        group IPV4-FUNET {
            /* Pääyhteyden IPv4 BGP-peeraus */
            neighbor 192.0.2.242 {
                description "BGP peering with AS1741 - primary";
                /* Käytetään BFD:tä BGP-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
    /* Määritetään IGP IPv4:lle (OSPF) */
    ospf {
        /* Käytetään yhtä OSPF-aluetta */
        area 0.0.0.0 {
            /* Hyväksytään reitittimen oma osoite IGP:hen, ei sessiota */
            interface lo0.0 {
                passive;
            }
            /* Hyväksytään Funet-yhteyden linkkiverkko IGP:hen, ei sessiota */
            interface ge-0/0/0.0 {
                passive;
            }
            /* Hyväksytään reitittimien välinen linkkiverkko IGP:hen, muodostetaan sessio */
            interface ge-0/0/1.0 {
                /* Käytetään BFD:tä OSPF-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
}

 

Customer rtr1 (IPv6)

interfaces {
    /* Funet-pääyhteyden liitäntä ge-0/0/0 */
    ge-0/0/0 {
        unit 0 {
            /* IPv6-linkkiverkko ja suodatukset Funet-pääyhteydellä */
            family inet6 {
                filter {
                    input FW-IPV6-FUNET-IN;
                    output FW-IPV6-FUNET-OUT;
                }
                address 2001:DB8:100:F000::1/126;
            }
        }
    }
    /* Omien reitittimien (rtr1 - rtr2) välinen liitäntä ge-0/0/1 */
    ge-0/0/1 {
        unit 0 {
            /* IPv6-linkkiverkko reitittimien välisellä yhteydellä */
            family inet6 {
                address 2001:DB8:100:F002::1/126;
            }
        }
    }
    /* Reitittimen loopback (reitittimen oma osoite) */
    lo0 {
        unit 0 {
            /* Reitittimen IPv6-osoite, määritetään ensisijaiseksi */
            family inet6 {
                address 2001:DB8:100:FFFF::1/128 {
                    primary;
                    preferred;
                }
            }
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv6 IBGP-peerauksia varten */
        group IPV6-INTERNAL {
            /* Käytetään EBGP:tä */
            type internal;
            /* Mainostetaan aina ulkoa opitut reitit */
            advertise-external;
            /* Asetetaan BGP holdtime 20s */
            hold-time 20;
            /* Hyväksytään IPv6 unicast ja multicast -peeraukset */
            family inet6 {
                any;
            }
            /* Peerauskumppanin AS-numero (oma) */
            peer-as 65099;
            /* IPv6 IBGP-peeraus */
            neighbor 2001:DB8:100:FFFF::2 {
                description "IPv6 IBGP peering with AS65099 - rtr2";
            }
        }
        /* Ryhmä IPv6 Funet EBGP-peerauksia varten */
        group IPV6-FUNET {
            /* Pääyhteyden IPv6 BGP-peeraus */
            neighbor 2001:DB8:100:F000::2 {
                description "IPv6 BGP peering with AS1741 - primary";
            }
        }
    }
    /* Määritetään IGP IPv6:lle (OSPFv3) */
    ospf3 {
        /* Käytetään yhtä OSPFv3-aluetta */
        area 0.0.0.0 {
            /* Hyväksytään reitittimen oma osoite IGP:hen, ei sessiota */
            interface lo0.0 {
                passive;
            }
            /* Hyväksytään Funet-yhteyden linkkiverkko IGP:hen, ei sessiota */
            interface ge-0/0/0.0 {
                passive;
            }
            /* Hyväksytään reitittimien välinen linkkiverkko IGP:hen, muodostetaan sessio */
            interface ge-0/0/1.0 {
                /* Käytetään BFD:tä OSPFv3-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
}

 

Customer rtr2 (IPv4)

interfaces {
    /* Funet-varayhteyden liitäntä ge-0/0/0 */
    ge-0/0/0 {
        description "Funet secondary";
        unit 0 {
            /* IPv4-linkkiverkko ja suodatukset Funet-varayhteydellä */
            family inet {
                filter {
                    input FW-IPV4-FUNET-IN;
                    output FW-IPV4-FUNET-OUT;
                }
                address 192.0.2.245/30;
            }
        }
    }
    /* Omien reitittimien (rtr2 - rtr1) välinen liitäntä ge-0/0/1 */
    ge-0/0/1 {
        description "rtr2 - rtr1";
        unit 0 {
            /* IPv4-linkkiverkko reitittimien välisellä yhteydellä */
            family inet {
                address 192.0.2.250/30;
            }
        }
    }
    /* Reitittimen loopback (reitittimen oma osoite) */
    lo0 {
        unit 0 {
            /* Reitittimen IPv4-osoite, määritetään ensisijaiseksi */
            family inet {
                address 192.0.2.254/32 {
                    primary;
                    preferred;
                }
            }
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv4 IBGP-peerauksia varten */
        group IPV4-INTERNAL {
            /* Käytetään IBGP:tä */
            type internal;
            /* Mainostetaan aina ulkoa opitut reitit */
            advertise-external;
            /* Asetetaan BGP holdtime 20s */
            hold-time 20;
            /* Hyväksytään IPv4 unicast ja multicast -peeraukset */
            family inet {
                any;
            }
            /* Peerauskumppanin AS-numero (oma) */
            peer-as 65099;
            /* IPv4 IBGP-peeraus */
            neighbor 192.0.2.253 {
                description "IBGP peering with AS65099 - rtr1";
            }
        }
        /* Ryhmä IPv4 Funet EBGP-peerauksia varten */
        group IPV4-FUNET {
            /* Varayhteyden IPv4 BGP-peeraus */
            neighbor 192.0.2.246 {
                description "BGP peering with AS1741 - secondary";
                /* Käytetään BFD:tä BGP-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
    /* Määritetään IGP IPv4:lle (OSPF) */
    ospf {
        /* Käytetään yhtä OSPF-aluetta */
        area 0.0.0.0 {
            /* Hyväksytään reitittimen oma osoite IGP:hen, ei sessiota */
            interface lo0.0 {
                passive;
            }
            /* Hyväksytään Funet-yhteyden linkkiverkko IGP:hen, ei sessiota */
            interface ge-0/0/0.0 {
                passive;
            }
            /* Hyväksytään reitittimien välinen linkkiverkko IGP:hen, muodostetaan sessio */
            interface ge-0/0/1.0 {
                /* Käytetään BFD:tä OSPF-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
}

 

Customer rtr2 (IPv6)

interfaces {
    /* Funet-varayhteyden liitäntä ge-0/0/0 */
    ge-0/0/0 {
        unit 0 {
            /* IPv6-linkkiverkko ja suodatukset Funet-varayhteydellä */
            family inet6 {
                filter {
                    input FW-IPV6-FUNET-IN;
                    output FW-IPV6-FUNET-OUT;
                }
                address 2001:DB8:100:F001::1/126;
            }
        }
    }
    /* Omien reitittimien (rtr2 - rtr1) välinen liitäntä ge-0/0/1 */
    ge-0/0/1 {
        unit 0 {
            /* IPv6-linkkiverkko reitittimien välisellä yhteydellä */
            family inet6 {
                address 2001:DB8:100:F002::2/126;
            }
        }
    }
    /* Reitittimen loopback (reitittimen oma osoite) */
    lo0 {
        unit 0 {
            /* Reitittimen IPv6-osoite, määritetään ensisijaiseksi */
            family inet6 {
                address 2001:DB8:100:FFFF::2/128 {
                    primary;
                    preferred;
                }
            }
        }
    }
}
protocols {
    bgp {
        /* Ryhmä IPv6 IBGP-peerauksia varten */
        group IPV6-INTERNAL {
            /* Käytetään EBGP:tä */
            type internal;
            /* Mainostetaan aina ulkoa opitut reitit */
            advertise-external;
            /* Asetetaan BGP holdtime 20s */
            hold-time 20;
            /* Hyväksytään IPv6 unicast ja multicast -peeraukset */
            family inet6 {
                any;
            }
            /* Peerauskumppanin AS-numero (oma) */
            peer-as 65099;
            /* IPv6 IBGP-peeraus */
            neighbor 2001:DB8:100:FFFF::1 {
                description "IPv6 IBGP peering with AS65099 - rtr1";
            }
        }
        /* Ryhmä IPv6 Funet EBGP-peerauksia varten */
        group IPV6-FUNET {
            /* Varayhteyden IPv6 BGP-peeraus */
            neighbor 2001:DB8:100:F001::2 {
                description "IPv6 BGP peering with AS1741 - secondary";
            }
        }
    }
    /* Määritetään IGP IPv6:lle (OSPFv3) */
    ospf3 {
        /* Käytetään yhtä OSPFv3-aluetta */
        area 0.0.0.0 {
            /* Hyväksytään reitittimen oma osoite IGP:hen, ei sessiota */
            interface lo0.0 {
                passive;
            }
            /* Hyväksytään Funet-yhteyden linkkiverkko IGP:hen, ei sessiota */
            interface ge-0/0/0.0 {
                passive;
            }
            /* Hyväksytään reitittimien välinen linkkiverkko IGP:hen, muodostetaan sessio */
            interface ge-0/0/1.0 {
                /* Käytetään BFD:tä OSPFv3-session katkaisun nopeuttamiseen virhetilanteessa (3*1s) */
                bfd-liveness-detection {
                    minimum-interval 1000;
                }
            }
        }
    }
}