Skip to end of metadata
Go to start of metadata
Tämän sivun sisältö:
 
 

Johdanto

Varayhteys voidaan toteuttaa joko yhdellä tai kahdella reunalaitteella.

Yhden reunalaitteen mallissa external BGP (EBGP) -sessiot luodaan asiakasreunalaitteen ja kahden Funetin reitittimen välille. Sisäverkon IGP-reititysprotokollia (kuten OSPF tai OSPFv3) ei varayhteyden toteuttamiseen tarvita, mutta niitä voidaan kyllä käyttää, jos sisäverkko niitä muuten hyödyntää. EBGP:n apuna voidaan käyttää Bidirectional Forwarding Detection (BFD) -protokollaa, jolla mahdollinen yhteyskatko on mahdollista huomata nopeammin.

Kahden reunalaitteen mallissa EBGP-sessio luodaan molemmista asiakasreunalaitteista johonkin Funetin reitittimeen. Reunalaitteiden välille rakennetaan internal BGP (IBGP) sessio, jolla reunalaitteet vaihtavat reittitietojaan. Sisäverkon reititysprotokollia käytetään reunalaitteiden tekniseen kytkentään, eli mainostamaan laitteiden loopback-liitäntöjä ja reitittimien välisiä linkkiverkkoja. Myös BFD:tä voidaan hyödyntää yhden reitittimen mallin tapaan.

Konfigurointiesimerkeissä on käytetty dokumentointiin varattuja osoiteavaruuksia sekä muita esimerkkiparametrejä kuten verkkoliitännät ja AS-numero, jotka pitää korvata kyseisen toteutuksen tiedoilla. Konfiguraatioesimerkit on lisäksi jaettu kahteen osaan: reitittimien lopullinen konfiguraatio koostuu yhteisestä osasta ja reititinkohtaisesta osasta, joka täydentää yhteistä konfiguraatiota. Tämän ohella on huomioitavaa, että IPv6-konfiguraatio täydentää myös IPv4-konfiguraatiota.

Alla on lyhyesti listattuna parametrit, jotka täytyy muuttaa käyttökohteen mukaisiksi. Parametreistä kannattaa huomioida Ciscon IOS:n notaatioerot verkon peitteissä: normaali verkon peite (esim. 255.255.255.0), käänteinen verkon peite (esim. 0.0.0.255) ja CIDR-notaatio (esim. /24).

Yhden reunalaitteen malli (kuvat 1 ja 2):

  • GigabitEthernet1/1              (pääyhteyden liitäntä)
  • GigabitEthernet1/2              (varayhteyden liitäntä)
  • 192.0.2.253                     (reunalaitteen IPv4 loopback -osoite)
  • 192.0.2.240/30                  (pääyhteyden IPv4-linkkiverkko)
  • 192.0.2.244/30                  (varayhteyden IPv4-linkkiverkko)
  • 192.0.2.0/24                    (organisaation IPv4-osoiteavaruus)
  • 2001:DB8:100:FFFF::1/128        (reunalaitteen IPv6 loopback -osoite)
  • 2001:DB8:100:F000::/126         (pääyhteyden IPv6-linkkiverkko, varattu koko /64, jota käytetään suodatuksissa)
  • 2001:DB8:100:F001::/126         (varayhteyden IPv6-linkkiverkko, varattu koko /64, jota käytetään suodatuksissa)
  • 2001:DB8:100::/48               (organisaation IPv6-osoiteavaruus)
  • 65099                           (organisaation AS-numero, privaatti-AS:n saa Funetilta kysymällä)

Kahden reunalaitteen malli (kuvat 3 ja 4):

  • GigabitEthernet1/1              (pää- tai varayhteyden liitäntä)
  • GigabitEthernet1/2              (reunalaitteiden välisen yhteyden liitäntä)
  • 192.0.2.253                     (pääyhteyden reunalaitteen IPv4 loopback -osoite)
  • 192.0.2.254                     (varayhteyden reunalaitteen IPv4 loopback -osoite)
  • 192.0.2.240/30                  (pääyhteyden IPv4-linkkiverkko)
  • 192.0.2.244/30                  (varayhteyden IPv4-linkkiverkko)
  • 192.0.2.248/30                  (reunalaitteiden välinen IPv4-linkkiverkko)
  • 192.0.2.0/24                    (organisaation IPv4-osoiteavaruus)
  • 2001:DB8:100:FFFF::1/128        (pääyhteyden reunalaitteen IPv6 loopback -osoite)
  • 2001:DB8:100:FFFF::2/128        (varayhteyden reunalaitteen IPv6 loopback -osoite)
  • 2001:DB8:100:F000::/126         (pääyhteyden IPv6-linkkiverkko, varattu koko /64, jota käytetään suodatuksissa)
  • 2001:DB8:100:F001::/126         (varayhteyden IPv6-linkkiverkko, varattu koko /64, jota käytetään suodatuksissa)
  • 2001:DB8:100:F002::/126         (reunalaitteiden välinen IPv6-linkkiverkko)
  • 2001:DB8:100::/48               (organisaation IPv6-osoiteavaruus)
  • 65099                           (organisaation AS-numero, privaatti-AS:n saa Funetilta kysymällä)

Vaihtoehdoista löytyy havainnekuvia (kuvat 1-4) alempaa konfiguraatioesimerkkien keskeltä.

 

BGP-varayhteys (yhteiset konfiguraatiot kaikkiin reitittimiin)

 

IPv4-konfiguraatiot (sisältäen yleiset asetukset)

! Estetään IPv4 lähdeosoitepohjainen reititys
no ip source-route
! Määritetään reititysprotokollat seuraamaan portin tilaa
ip routing protocol purge
! C6500: Estetään ICMP unreachable -viestien lähettäminen pudotetuista paketeista, 
! vaihtoehtoinen tapa "no ip unreachables" rikkoo PMTU:n
mls rate-limit unicast ip icmp unreachable acl-drop 0

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 no ip redirects
 no ip proxy-arp

! Funet-pää/varayhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 no ip redirects
 no ip proxy-arp
 logging event link-status

! Funet-varayhteyden/iBGP-yhteyden liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 no ip redirects
 no ip proxy-arp
 logging event link-status

! Määritetään suodatin IPv4 Funet-yhteydelle (sisääntuleva liikenne)
! 1-2. Hyväksytään kaikki linkkiverkoista tuleva liikenne
! 3. Hylätään omat prefiksit lähdeosoitteina
! 4-5. Hyväksytään omat prefiksit kohdeosoitteina ja multicast
! 6. Hylätään muut
ip access-list extended funet_in
 permit ip 192.0.2.240 0.0.0.3 any
 permit ip 192.0.2.244 0.0.0.3 any
 deny   ip 192.0.2.0 0.0.0.255 any
 permit ip any 192.0.2.0 0.0.0.255
 permit ip any 224.0.0.0 15.255.255.255
 deny   ip any any

! Määritetään suodatin IPv4 Funet-yhteydelle (ulospäin lähtevä liikenne)
! 1-2. Hyväksytään kaikki linkkiverkoista lähtevä liikenne
! 3. Hyväksytään omat prefiksit lähdeosoitteina
! 4. Hylätään muut
ip access-list extended funet_out
 permit ip 192.0.2.240 0.0.0.3 any
 permit ip 192.0.2.244 0.0.0.3 any
 permit ip 192.0.2.0 0.0.0.255 any
 deny   ip any any

! Määritetään IPv4 default-prefiksi
ip prefix-list default-prefix seq 10 permit 0.0.0.0/0

! Määritetään omat IPv4-prefiksit
ip prefix-list own-prefixes seq 10 permit 192.0.2.0/24

! Määritetään policy Funetin IPv4 BGP-mainostuksille (default)
route-map funet-in permit 10
 match ip address prefix-list default-prefix

! Määritetään policy omille IPv4 BGP-mainostuksille (omat prefiksit)
route-map funet-out permit 10
 match ip address prefix-list own-prefixes

! Määritetään BGP-konfiguraatio omalle AS-numerolle
router bgp 65099
 ! Lokitetaan BGP-sessioiden heilumiset
 bgp log-neighbor-changes
 ! Poistetaan käytöstä automaattiset IPv4-peeraukset
 no bgp default ipv4-unicast

 address-family ipv4
  ! Poistetaan käytöstä aggregaattiprefiksien automaattinen generointi
  no auto-summary
  ! Poistetaan käytöstä iBGP-reittien validointi IGP:llä
  no synchronization

  ! Määritetään mainostettava prefiksi (oma)
  network 192.0.2.0 mask 255.255.255.0
 exit-address-family

! Staattinen IPv4 null0-reitti omille osoiteprefikseille
ip route 192.0.2.0 255.255.255.0 Null0 250

 

IPv6 -konfiguraatiot (lisäyksenä IPv4-konfiguraatioihin)

! Estetään IPv6 lähdeosoitepohjainen reititys
no ipv6 source-route
! Kytketään IPv6 unicast-reititys käyttöön
ipv6 unicast-routing
! C6500: otetaan käyttöön IPv6-osoitteiden pakkaus suodattimissa, jotta esim. TCP/UDP-portteja voidaan hyödyntää suodattimissa
mls ipv6 acl compress address unicast

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 no ipv6 redirects

! Funet-pää/varayhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 ipv6 nd ra suppress
 no ipv6 redirects

! Funet-varayhteyden/iBGP-yhteyden liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 ipv6 nd ra suppress
 no ipv6 redirects

! Määritetään suodatin IPv6 Funet-yhteydelle (sisääntuleva liikenne)
! 1-3. Hyväksytään kaikki linkkiverkoista tuleva liikenne
! 4. Hylätään omat prefiksit lähdeosoitteina
! 5-7. Hyväksytään omat prefiksit kohdeosoitteina ja multicast
! 8. Hylätään muut
ipv6 access-list funet_6in
 permit ipv6 2001:DB8:100:F000::/64 any
 permit ipv6 2001:DB8:100:F001::/64 any
 permit ipv6 FE80::/10 any
 deny   ipv6 2001:DB8:100::/48 any
 permit ipv6 any 2001:DB8:100::/48
 permit ipv6 any FE80::/10
 permit ipv6 any FF00::/8
 deny   ipv6 any any

! Määritetään suodatin IPv6 Funet-yhteydelle (ulospäin lähtevä liikenne)
! 1-3. Hyväksytään kaikki linkkiverkosta lähtevä liikenne
! 4. Hyväksytään omat prefiksit lähdeosoitteina
! 5. Hylätään muut
ipv6 access-list funet_6out
 permit ipv6 2001:DB8:100:F000::/64 any
 permit ipv6 2001:DB8:100:F001::/64 any
 permit ipv6 FE80::/10 any
 permit ipv6 2001:DB8:100::/48 any
 deny   ipv6 any any

! Määritetään IPv6 default-prefiksi
ipv6 prefix-list ipv6-default-prefix seq 10 permit ::/0

! Määritetään omat IPv6-prefiksit
ipv6 prefix-list ipv6-own-prefixes seq 10 permit 2001:DB8:100::/48

! Määritetään policy Funetin IPv6 BGP-mainostuksille (default)
route-map ipv6-funet-in permit 10
 match ipv6 address prefix-list ipv6-default-prefix

! Määritetään policy omille IPv6 BGP-mainostuksille (omat prefiksit)
route-map ipv6-funet-out permit 10
 match ipv6 address prefix-list ipv6-own-prefixes

! Määritetään BGP-konfiguraatio omalle AS-numerolle
router bgp 65099
 address-family ipv6
  ! Poistetaan käytöstä iBGP-reittien validointi IGP:llä
  no synchronization

  ! Määritetään mainostettava prefiksi (oma)
  network 2001:DB8:100::/48
 exit-address-family

! Staattinen IPv6 null0-reitti omille osoiteprefikseille
ipv6 route 2001:DB8:100::/48 Null0 250

 

BGP-varayhteys yhdellä reitittimellä (optiona BFD)

 

Kuva 1: BGP-varayhteys yhdellä reitittimellä ilman BFD:tä

 

Kuva 2: BGP-varayhteys yhdellä reitittimellä BFD:n kanssa

 

Customer rtr1 (IPv4)

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 ! Reitittimen IPv4-osoite
 ip address 192.0.2.253 255.255.255.255

! Funet-pääyhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 description Funet primary
 ! IPv4-linkkiverkko ja suodatukset Funet-pääyhteydellä
 ip address 192.0.2.241 255.255.255.252
 ip access-group funet_in in
 ip access-group funet_out out
 ! Optio: aktivoidaan BFD liitännässä (3*1s), protokollista BGP käyttää
 bfd interval 1000 min_rx 1000 multiplier 3
 no cdp enable
 no lldp transmit
 no lldp receive
 spanning-tree bpdufilter enable

! Funet-varayhteyden liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 description Funet secondary
 ! IPv4-linkkiverkko ja suodatukset Funet-varayhteydellä
 ip address 192.0.2.245 255.255.255.252
 ip access-group funet_in in
 ip access-group funet_out out
 ! Optio: aktivoidaan BFD liitännässä (3*1s), protokollista BGP käyttää
 bfd interval 1000 min_rx 1000 multiplier 3
 no cdp enable
 no lldp transmit
 no lldp receive
 spanning-tree bpdufilter enable

! Määritetään BGP-konfiguraatio IPv4:lle
router bgp 65099
 ! Määritetään ID (reitittimen IPv4 loopback-osoite)
 bgp router-id 192.0.2.253

 ! Määritetään Funet-pääyhteyden IPv4 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, optiona: hyödynnetään BFD:tä
 neighbor 192.0.2.242 remote-as 1741
 neighbor 192.0.2.242 description BGP peering with AS1741 - primary
 neighbor 192.0.2.242 timers 7 21
 neighbor 192.0.2.242 fall-over bfd

 ! Määritetään Funet-varayhteyden IPv4 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, optiona: hyödynnetään BFD:tä
 neighbor 192.0.2.246 remote-as 1741
 neighbor 192.0.2.246 description BGP peering with AS1741 - secondary
 neighbor 192.0.2.246 timers 7 21
 neighbor 192.0.2.246 fall-over bfd

 ! Määritetään IPv4 unicast BGP-peeraukset
 address-family ipv4
  ! 1. Aktivoidaan pääyhteyden IPv4 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 192.0.2.242 activate
  neighbor 192.0.2.242 soft-reconfiguration inbound
  neighbor 192.0.2.242 route-map funet-in in
  neighbor 192.0.2.242 route-map funet-out out

  ! 1. Aktivoidaan varayhteyden IPv4 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 192.0.2.246 activate
  neighbor 192.0.2.246 soft-reconfiguration inbound
  neighbor 192.0.2.246 route-map funet-in in
  neighbor 192.0.2.246 route-map funet-out out
 exit-address-family

 

Customer rtr1 (IPv6)

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 ! Reitittimen IPv6-osoite
 ipv6 address 2001:DB8:100:FFFF::1/128

! Funet-pääyhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 ! IPv6-linkkiverkko ja suodatukset Funet-pääyhteydellä
 ipv6 address 2001:DB8:100:F000::1/126
 ipv6 traffic-filter funet_6in in
 ipv6 traffic-filter funet_6out out
 no ipv6 mld router

! Funet-varayhteyden liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 ! IPv6-linkkiverkko ja suodatukset Funet-varayhteydellä
 ipv6 address 2001:DB8:100:F001::1/126
 ipv6 traffic-filter funet_6in in
 ipv6 traffic-filter funet_6out out
 no ipv6 mld router

! Määritetään BGP-konfiguraatio IPv6:lle
router bgp 65099
 ! Määritetään Funet-pääyhteyden IPv6 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, ei BFD:tä, koska ei ole tuettu
 neighbor 2001:DB8:100:F000::2 remote-as 1741
 neighbor 2001:DB8:100:F000::2 description IPv6 BGP peering with AS1741 - primary
 neighbor 2001:DB8:100:F000::2 timers 7 21
 neighbor 2001:DB8:100:F000::2 fall-over

 ! Määritetään Funet-varayhteyden IPv6 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, ei BFD:tä, koska ei ole tuettu
 neighbor 2001:DB8:100:F001::2 remote-as 1741
 neighbor 2001:DB8:100:F001::2 description IPv6 BGP peering with AS1741 - secondary
 neighbor 2001:DB8:100:F001::2 timers 7 21
 neighbor 2001:DB8:100:F001::2 fall-over

 ! Määritetään IPv6 unicast BGP-peeraukset
 address-family ipv6
  ! 1. Aktivoidaan pääyhteyden IPv6 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 2001:DB8:100:F000::2 activate
  neighbor 2001:DB8:100:F000::2 soft-reconfiguration inbound
  neighbor 2001:DB8:100:F000::2 route-map ipv6-funet-in in
  neighbor 2001:DB8:100:F000::2 route-map ipv6-funet-out out

  ! 1. Aktivoidaan varayhteyden IPv6 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 2001:DB8:100:F001::2 activate
  neighbor 2001:DB8:100:F001::2 soft-reconfiguration inbound
  neighbor 2001:DB8:100:F001::2 route-map ipv6-funet-in in
  neighbor 2001:DB8:100:F001::2 route-map ipv6-funet-out out
 exit-address-family

 

BGP-varayhteys kahdella reitittimellä (optiona BFD)

 

Kuva 3: BGP-varayhteys kahdella reitittimellä ilman BFD:tä

 

Kuva 4: BGP-varayhteys kahdella reitittimellä BFD:n kanssa

 

Customer rtr1 (IPv4)

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 ! Reitittimen IPv4-osoite
 ip address 192.0.2.253 255.255.255.255

! Funet-pääyhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 description Funet primary
 ! IPv4-linkkiverkko ja suodatukset Funet-pääyhteydellä
 ip address 192.0.2.241 255.255.255.252
 ip access-group funet_in in
 ip access-group funet_out out
 ! Optio: aktivoidaan BFD liitännässä (3*1s), protokollista BGP käyttää
 bfd interval 1000 min_rx 1000 multiplier 3
 no cdp enable
 no lldp transmit
 no lldp receive
 spanning-tree bpdufilter enable

! Omien reitittimien (rtr1 - rtr2) välinen liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 description rtr1 - rtr2
 ! IPv4-linkkiverkko reitittimien välisellä yhteydellä
 ip address 192.0.2.249 255.255.255.252
 ! Optio: aktivoidaan BFD liitännässä (3*1s), protokollista OSPF käyttää
 bfd interval 1000 min_rx 1000 multiplier 3

! Määritetään IGP IPv4:lle (OSPF)
! 1. Määritetään ID (reitittimen IPv4 loopback-osoite)
! 2. Aktivoidaan Incremental SPF
! 3. Lokitetaan OSPF-sessioiden heilumiset
! 4-8. Määritetään nopeammat ajastimet OSPF:lle
! 9. Optio: nopea toipuminen BFD:n avulla
! 10. Määritetään oletusarvoksi: ei OSPF-sessiota liitännöissä
! 11. Aktivoidaan OSPF reitittimien välisellä linkkiverkolla
! 12. Hyväksytään reitittimen oma osoite IGP:hen, ei sessiota
! 13. Hyväksytään Funet-yhteyden linkkiverkko IGP:hen, ei sessiota
! 14. Hyväksytään reitittimien välinen linkkiverkko IGP:hen
router ospf 1
 router-id 192.0.2.253
 ispf
 log-adjacency-changes
 timers throttle spf 10 100 1000
 timers throttle lsa all 10 100 1000
 timers lsa arrival 50
 timers pacing flood 5
 timers pacing retransmission 60
 bfd all-interfaces
 passive-interface default
 no passive-interface GigabitEthernet1/2
 network 192.0.2.253 0.0.0.0 area 0
 network 192.0.2.240 0.0.0.3 area 0
 network 192.0.2.248 0.0.0.3 area 0

! Määritetään BGP-konfiguraatio IPv4:lle
router bgp 65099
 ! Määritetään ID (reitittimen IPv4 loopback-osoite)
 bgp router-id 192.0.2.253

 ! Määritetään Funet-pääyhteyden IPv4 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, optiona: hyödynnetään BFD:tä
 neighbor 192.0.2.242 remote-as 1741
 neighbor 192.0.2.242 description BGP peering with AS1741 - primary
 neighbor 192.0.2.242 timers 7 21
 neighbor 192.0.2.242 fall-over bfd

 ! Määritetään omien reitittimien välinen IPv4 iBGP-peeraus
 ! 1. Määritetään iBGP-peerauskumppanin AS-numero (oma)
 ! 2. Asetetaan iBGP-peeraukselle kuvaus
 ! 3. Määritetään iBGP-peeraukselle lähdeliittymäksi Loopback0
 ! 4. Määritetään BGP-session pitoajaksi 21s
 ! 5. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu
 neighbor 192.0.2.250 remote-as 65099
 neighbor 192.0.2.250 description iBGP peering with AS65099
 neighbor 192.0.2.250 update-source Loopback0
 neighbor 192.0.2.250 timers 7 21
 neighbor 192.0.2.250 fall-over

 ! Määritetään IPv4 unicast BGP-peeraukset
 address-family ipv4
  ! 1. Aktivoidaan pääyhteyden IPv4 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 192.0.2.242 activate
  neighbor 192.0.2.242 soft-reconfiguration inbound
  neighbor 192.0.2.242 route-map funet-in in
  neighbor 192.0.2.242 route-map funet-out out

  ! 1. Aktivoidaan IPv4 iBGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  neighbor 192.0.2.250 activate
  neighbor 192.0.2.250 soft-reconfiguration inbound
 exit-address-family

 

Customer rtr1 (IPv6)

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 ! Reitittimen IPv6-osoite
 ipv6 address 2001:DB8:100:FFFF::1/128
 ! Aktivoidaan OSPFv3 liitännässä (passiivinen)
 ipv6 ospf 1 area 0

! Funet-pääyhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 ! IPv6-linkkiverkko ja suodatukset Funet-pääyhteydellä
 ipv6 address 2001:DB8:100:F000::1/126
 ipv6 traffic-filter funet_6in in
 ipv6 traffic-filter funet_6out out
 no ipv6 mld router
 ! Aktivoidaan OSPFv3 liitännässä (passiivinen)
 ipv6 ospf 1 area 0

! Omien reitittimien (rtr1 - rtr2) välinen liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 ! IPv6-linkkiverkko reitittimien välisellä yhteydellä
 ipv6 address 2001:DB8:100:F002::1/126
 ! Aktivoidaan OSPFv3 liitännässä
 ipv6 ospf 1 area 0

! Määritetään IGP IPv6:lle (OSPFv3)
! 1. Määritetään ID (reitittimen IPv4 loopback-osoite)
! 2. Lokitetaan OSPFv3-sessioiden heilumiset
! 3. Määritetään oletusarvoksi: ei OSPFv3-sessiota liitännöissä
! 4. Aktivoidaan OSPFv3 reitittimien välisellä linkkiverkolla
! 5. Määritetään nopeammat ajastimet OSPFv3:lle
ipv6 router ospf 1
 router-id 192.0.2.253
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet1/2
 timers spf 1 5

! Määritetään BGP-konfiguraatio IPv6:lle
router bgp 65099
 ! Määritetään Funet-pääyhteyden IPv6 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, ei BFD:tä, koska ei ole tuettu
 neighbor 2001:DB8:100:F000::2 remote-as 1741
 neighbor 2001:DB8:100:F000::2 description IPv6 BGP peering with AS1741 - primary
 neighbor 2001:DB8:100:F000::2 timers 7 21
 neighbor 2001:DB8:100:F000::2 fall-over

 ! Määritetään omien reitittimien välinen IPv6 iBGP-peeraus
 ! 1. Määritetään iBGP-peerauskumppanin AS-numero (oma)
 ! 2. Asetetaan iBGP-peeraukselle kuvaus
 ! 3. Määritetään iBGP-peeraukselle lähdeliittymäksi Loopback0
 ! 4. Määritetään BGP-session pitoajaksi 21s
 ! 5. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu
 neighbor 2001:DB8:100:F002::2 remote-as 65099
 neighbor 2001:DB8:100:F002::2 description IPv6 iBGP peering with AS65099
 neighbor 2001:DB8:100:F002::2 update-source Loopback0
 neighbor 2001:DB8:100:F002::2 timers 7 21
 neighbor 2001:DB8:100:F002::2 fall-over

 ! Määritetään IPv6 unicast BGP-peeraukset
 address-family ipv6
  ! 1. Aktivoidaan pääyhteyden IPv6 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 2001:DB8:100:F000::2 activate
  neighbor 2001:DB8:100:F000::2 soft-reconfiguration inbound
  neighbor 2001:DB8:100:F000::2 route-map ipv6-funet-in in
  neighbor 2001:DB8:100:F000::2 route-map ipv6-funet-out out

  ! 1. Aktivoidaan IPv6 iBGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  neighbor 2001:DB8:100:F002::2 activate
  neighbor 2001:DB8:100:F002::2 soft-reconfiguration inbound
 exit-address-family

 

Customer rtr2 (IPv4)

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 ! Reitittimen IPv4-osoite
 ip address 192.0.2.254 255.255.255.255

! Funet-varayhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 description Funet secondary
 ! IPv4-linkkiverkko ja suodatukset Funet-varayhteydellä
 ip address 192.0.2.245 255.255.255.252
 ip access-group funet_in in
 ip access-group funet_out out
 ! Optio: aktivoidaan BFD liitännässä (3*1s), protokollista BGP käyttää
 bfd interval 1000 min_rx 1000 multiplier 3
 no cdp enable
 no lldp transmit
 no lldp receive
 spanning-tree bpdufilter enable

! Omien reitittimien (rtr2 - rtr1) välinen liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 description rtr2 - rtr1
 ! IPv4-linkkiverkko reitittimien välisellä yhteydellä
 ip address 192.0.2.250 255.255.255.252
 ! Optio: aktivoidaan BFD liitännässä (3*1s), protokollista OSPF käyttää
 bfd interval 1000 min_rx 1000 multiplier 3

! Määritetään IGP IPv4:lle (OSPF)
! 1. Määritetään ID (reitittimen IPv4 loopback-osoite)
! 2. Aktivoidaan Incremental SPF
! 3. Lokitetaan OSPF-sessioiden heilumiset
! 4-8. Määritetään nopeammat ajastimet OSPF:lle
! 9. Optio: nopea toipuminen BFD:n avulla
! 10. Määritetään oletusarvoksi: ei OSPF-sessiota liitännöissä
! 11. Aktivoidaan OSPF reitittimien välisellä linkkiverkolla
! 12. Hyväksytään reitittimen oma osoite IGP:hen, ei sessiota
! 13. Hyväksytään Funet-yhteyden linkkiverkko IGP:hen, ei sessiota
! 14. Hyväksytään reitittimien välinen linkkiverkko IGP:hen
router ospf 1
 router-id 192.0.2.254
 ispf
 log-adjacency-changes
 timers throttle spf 10 100 1000
 timers throttle lsa all 10 100 1000
 timers lsa arrival 50
 timers pacing flood 5
 timers pacing retransmission 60
 bfd all-interfaces
 passive-interface default
 no passive-interface GigabitEthernet1/2
 network 192.0.2.254 0.0.0.0 area 0
 network 192.0.2.244 0.0.0.3 area 0
 network 192.0.2.248 0.0.0.3 area 0

! Määritetään BGP-konfiguraatio IPv4:lle
router bgp 65099
 ! Määritetään ID (reitittimen IPv4 loopback-osoite)
 bgp router-id 192.0.2.254

 ! Määritetään Funet-varayhteyden IPv4 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, optiona: hyödynnetään BFD:tä
 neighbor 192.0.2.246 remote-as 1741
 neighbor 192.0.2.246 description BGP peering with AS1741 - secondary
 neighbor 192.0.2.246 timers 7 21
 neighbor 192.0.2.246 fall-over bfd

 ! Määritetään omien reitittimien välinen IPv4 iBGP-peeraus
 ! 1. Määritetään iBGP-peerauskumppanin AS-numero (oma)
 ! 2. Asetetaan iBGP-peeraukselle kuvaus
 ! 3. Määritetään iBGP-peeraukselle lähdeliittymäksi Loopback0
 ! 4. Määritetään BGP-session pitoajaksi 21s
 ! 5. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu
 neighbor 192.0.2.249 remote-as 65099
 neighbor 192.0.2.249 description iBGP peering with AS65099
 neighbor 192.0.2.249 update-source Loopback0
 neighbor 192.0.2.249 timers 7 21
 neighbor 192.0.2.249 fall-over

 ! Määritetään IPv4 unicast BGP-peeraukset
 address-family ipv4
  ! 1. Aktivoidaan varayhteyden IPv4 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 192.0.2.246 activate
  neighbor 192.0.2.246 soft-reconfiguration inbound
  neighbor 192.0.2.246 route-map funet-in in
  neighbor 192.0.2.246 route-map funet-out out

  ! 1. Aktivoidaan IPv4 iBGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  neighbor 192.0.2.249 activate
  neighbor 192.0.2.249 soft-reconfiguration inbound
 exit-address-family

 

Customer rtr2 (IPv6)

! Reitittimen loopback (reitittimen oma osoite)
interface Loopback0
 ! Reitittimen IPv6-osoite
 ipv6 address 2001:DB8:100:FFFF::2/128
 ! Aktivoidaan OSPFv3 liitännässä (passiivinen)
 ipv6 ospf 1 area 0

! Funet-varayhteyden liitäntä GigabitEthernet1/1
interface GigabitEthernet1/1
 ! IPv6-linkkiverkko ja suodatukset Funet-varayhteydellä
 ipv6 address 2001:DB8:100:F001::1/126
 ipv6 traffic-filter funet_6in in
 ipv6 traffic-filter funet_6out out
 no ipv6 mld router
 ! Aktivoidaan OSPFv3 liitännässä (passiivinen)
 ipv6 ospf 1 area 0

! Omien reitittimien (rtr2 - rtr1) välinen liitäntä GigabitEthernet1/2
interface GigabitEthernet1/2
 ! IPv6-linkkiverkko reitittimien välisellä yhteydellä
 ipv6 address 2001:DB8:100:F002::2/126
 ! Aktivoidaan OSPFv3 liitännässä
 ipv6 ospf 1 area 0

! Määritetään IGP IPv6:lle (OSPFv3)
! 1. Määritetään ID (reitittimen IPv4 loopback-osoite)
! 2. Lokitetaan OSPFv3-sessioiden heilumiset
! 3. Määritetään oletusarvoksi: ei OSPFv3-sessiota liitännöissä
! 4. Aktivoidaan OSPFv3 reitittimien välisellä linkkiverkolla
! 5. Määritetään nopeammat ajastimet OSPFv3:lle
ipv6 router ospf 1
 router-id 192.0.2.254
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet1/2
 timers spf 1 5

! Määritetään BGP-konfiguraatio IPv6:lle
router bgp 65099
 ! Määritetään Funet-varayhteyden IPv6 BGP-peeraus
 ! 1. Määritetään BGP-peerauskumppanin AS-numero (Funet)
 ! 2. Asetetaan BGP-peeraukselle kuvaus 
 ! 3. Määritetään BGP-session pitoajaksi 21s
 ! 4. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu, ei BFD:tä, koska ei ole tuettu
 neighbor 2001:DB8:100:F001::2 remote-as 1741
 neighbor 2001:DB8:100:F001::2 description IPv6 BGP peering with AS1741 - secondary
 neighbor 2001:DB8:100:F001::2 timers 7 21
 neighbor 2001:DB8:100:F001::2 fall-over

 ! Määritetään omien reitittimien välinen IPv6 iBGP-peeraus
 ! 1. Määritetään iBGP-peerauskumppanin AS-numero (oma)
 ! 2. Asetetaan iBGP-peeraukselle kuvaus
 ! 3. Määritetään iBGP-peeraukselle lähdeliittymäksi Loopback0
 ! 4. Määritetään BGP-session pitoajaksi 21s
 ! 5. Otetaan käyttöön nopeampi BGP-sessiokohtainen tapahtumapohjainen katkaisu
 neighbor 2001:DB8:100:F002::1 remote-as 65099
 neighbor 2001:DB8:100:F002::1 description IPv6 iBGP peering with AS65099
 neighbor 2001:DB8:100:F002::1 update-source Loopback0
 neighbor 2001:DB8:100:F002::1 timers 7 21
 neighbor 2001:DB8:100:F002::1 fall-over

 ! Määritetään IPv6 unicast BGP-peeraukset
 address-family ipv6
  ! 1. Aktivoidaan varayhteyden IPv6 BGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  ! 3. Suodatetaan Funetin mainostuksia (default-reitti)
  ! 4. Suodatetaan omia mainostuksia (omat prefiksit)
  neighbor 2001:DB8:100:F001::2 activate
  neighbor 2001:DB8:100:F001::2 soft-reconfiguration inbound
  neighbor 2001:DB8:100:F001::2 route-map ipv6-funet-in in
  neighbor 2001:DB8:100:F001::2 route-map ipv6-funet-out out

  ! 1. Aktivoidaan IPv6 iBGP-peeraus
  ! 2. Aktivoidaan BGP-reittien tallennus, mahdollistaa sisäänpäin tulevien mainostusten näkemisen
  neighbor 2001:DB8:100:F002::1 activate
  neighbor 2001:DB8:100:F002::1 soft-reconfiguration inbound
 exit-address-family